Setting up a Cisco 800 series Router for ADSL
Not that the Average user would use a Cisco ADSL router, or if they do use a Cisco product it would probably be a Linksys router.
Anyway here is the config with comments in between. all comments are in italics
You might want to check out the Cisco DYNDNS configuration guide too
NOTE: This particular config was done on a Cisco 877 ADSL / DSL router however its known to work on the Cisco 800 series DSL routers in general including the Cisco 827 Cisco 837 Cisco 877W
This example is a basic setup for just access to the web you can enable PAT or Port Address Translation on the router to allow access from the outside to a server or something like that. Also this setup is for a Dynamic IP from the ISP
you might also want to checko out the how to on setting up SSH login on the router
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname # your router name i.e. Bobs Router
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret Your Enable Secret
!
no aaa new-model
ip subnet-zero
ip dhcp excluded-address 192.168.0.100 #IPs you want to have as static addresses to be excluded from the Pool
ip dhcp excluded-address 192.168.0.7
ip dhcp excluded-address 192.168.0.2
!
ip dhcp pool MYPOOL
network 192.168.0.0 255.255.255.0 #Your Internal IP range
dns-server # your ISP's DNS Server IP Addresses
default-router 192.168.0.1 #The Address of this Router
!
!
ip cef
ip audit notify log
ip audit po max-events 100
ip ssh break-string
vpdn enable
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
no ftp-server write-enable
no scripting tcl init
no scripting tcl encdir
!
!
!
!
interface Ethernet0
ip address 192.168.0.1 255.255.255.0
ip nat inside
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
hold-queue 224 in
!
interface ATM0.1 point-to-point
pvc 8/35 # the PVC Address Telkom in South Africa use 8/35 your particular Telco provider probably uses something else
pppoe-client dial-pool-number 1
!
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 2
ppp chap hostname your ISP username goes here
ppp pap sent-username your ISP username goes here password your ISP password goes here
!
ip nat inside source interface Dialer1 overload This enables NAT on your router to mask your internal range to the external IP address
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
no ip http secure-server
!
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
line con 0
exec-timeout 120 0
logging synchronous
no modem enable
transport preferred all
transport output all
stopbits 1
line aux 0
transport preferred all
transport output all
line vty 0 4
access-class 1 in
exec-timeout 120 0
password # your password goes here to telnet into your router
login
length 0
transport preferred all
transport input all
transport output all
!
scheduler max-task-time 5000
sntp server (optional)
!
end
Not that the Average user would use a Cisco ADSL router, or if they do use a Cisco product it would probably be a Linksys router.
Anyway here is the config with comments in between. all comments are in italics
You might want to check out the Cisco DYNDNS configuration guide too
NOTE: This particular config was done on a Cisco 877 ADSL / DSL router however its known to work on the Cisco 800 series DSL routers in general including the Cisco 827 Cisco 837 Cisco 877W
This example is a basic setup for just access to the web you can enable PAT or Port Address Translation on the router to allow access from the outside to a server or something like that. Also this setup is for a Dynamic IP from the ISP
you might also want to checko out the how to on setting up SSH login on the router
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname # your router name i.e. Bobs Router
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret Your Enable Secret
!
no aaa new-model
ip subnet-zero
ip dhcp excluded-address 192.168.0.100 #IPs you want to have as static addresses to be excluded from the Pool
ip dhcp excluded-address 192.168.0.7
ip dhcp excluded-address 192.168.0.2
!
ip dhcp pool MYPOOL
network 192.168.0.0 255.255.255.0 #Your Internal IP range
dns-server # your ISP's DNS Server IP Addresses
default-router 192.168.0.1 #The Address of this Router
!
!
ip cef
ip audit notify log
ip audit po max-events 100
ip ssh break-string
vpdn enable
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
no ftp-server write-enable
no scripting tcl init
no scripting tcl encdir
!
!
!
!
interface Ethernet0
ip address 192.168.0.1 255.255.255.0
ip nat inside
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
hold-queue 224 in
!
interface ATM0.1 point-to-point
pvc 8/35 # the PVC Address Telkom in South Africa use 8/35 your particular Telco provider probably uses something else
pppoe-client dial-pool-number 1
!
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 2
ppp chap hostname your ISP username goes here
ppp pap sent-username your ISP username goes here password your ISP password goes here
!
ip nat inside source interface Dialer1 overload This enables NAT on your router to mask your internal range to the external IP address
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
no ip http secure-server
!
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
line con 0
exec-timeout 120 0
logging synchronous
no modem enable
transport preferred all
transport output all
stopbits 1
line aux 0
transport preferred all
transport output all
line vty 0 4
access-class 1 in
exec-timeout 120 0
password # your password goes here to telnet into your router
login
length 0
transport preferred all
transport input all
transport output all
!
scheduler max-task-time 5000
sntp server (optional)
!
end
Comments